Feature #1081

ruby1.8で実行しないといけないタスクの前にRubyのバージョンチェックを行う

Added by haruka yoshihara almost 7 years ago. Updated almost 7 years ago.

Status:完了チェック待ちStart date:09/27/2011
Priority:NormalDue date:09/27/2011
Assignee:haruka yoshihara% Done:

0%

Category:-Estimated time:1.00 hour
Target version:-

Description

h2. 問題

gemのビルドなど、ruby1.8でやらなければならないタスクが複数あるが、それらタスクを普通にrakeするとruby1.9.1で行なってしまい、エラーが出る。

h2. 期待する状態

ruby1.8で行わないといけないタスクの場合、普通にruby1.9.1でやろうとするとruby1.8でやるように警告が出る。

h2. 解決方法

rubyのバージョンをチェックするタスクを作り、それを1.8でやらないといけないタスクの前に依存関係を作り、そのタスクを実行する前にこのタスクが実行されるようにする。

History

#1 Updated by haruka yoshihara almost 7 years ago

  • Status changed from 新規 to 担当者作業中

#2 Updated by haruka yoshihara almost 7 years ago

  • Status changed from 担当者作業中 to 完了チェック待ち

Also available in: Atom PDF